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The Page Editor

All about your

Desktop Publisher

Desktop publishing is a term used to describe a
method of producing drawings and text, laying
them out electronically and printing the result — all
from the same system. With such a program it is
possible to produce smart, professional newsletters,
reports, leaflets and such like, exactly as you want
them with a minimum of skill or expertise.

The Desktop Publisher (DTP for short) is an all-
in-one typesetting and artwork package for the
PCW, designed for use with a mouse or from the
keyboard. It consists of three modules, each of
which performs a series of specific tasks.

The three modules are:

@® A Page Editor
@® A Text Editor
@® A Graphics Editor

This manual shows how to use each of these in
order to give the best possible results.

To design a page you must first get a rough idea of
how you want it to look. For instance, you need to
know how much space you wish to devote to text
and graphics. The Page Editor helps you to do this
by displaying a representation of the finished page
showing the positions of text and graphics windows
that you have created to your own dimensions. It
also allows you to move these around the page until
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The Text Editor

The Graphics
Editor

the layout is exactly as you require it.

These windows can be processed at any time
using the Text or Graphics editors. When
everything is complete and to your liking, the page
can be printed out in either draft or NLQ (near
letter quality) format.

Text windows are processed with the Text Editor.
It contains all the functions required to make
formatting and justification as simple as possible.
Character styles such as bold or italic are displayed
on the screen exactly as they will be printed out.
When sufficient text has been written te fill a
window, a message is displayed so that you can
extend the window if you wish. You can also import
text in the form of Ascii files created using Loco-
Script or other word processors such as WordStar.

The Graphics Editor simplifies the production of
clear, accurate drawings, graphs and charts. With
it you can:

Draw freehand

Create single or multiple lines and rays
Draw boxes, triangles and ellipses

Paint or fill areas in a variety of patterns
Edit detail by magnifying areas

Copy or move areas

Create enlarged text.

In addition you can incorporate images taken
from the Rombo Digitiser or Dart Scanner and
reduce or enlarge them to fit a pre-defined graphics
window.



Getting started

You can operate DTP using either a mouse or the
keyboard. On power up the package is set for key-
board control. This can be easily changed to cater
for a mouse using the Options menu (see later).

If you intend to use a mouse, first make sure it is
plugged in with the machine switched off.

Next load CP/M by placing your Amstrad system
disc in drive A and switching on the computer.
When it has finished loading your screen will dis-
play the A> prompt. At this point remove the disc
and insert your DTP disc. Type:

DTP

and press Return.

Once the software has loaded (this takes a little
while so be patient) a row of menu options will
appear at the top of the screen.

Of menus and pointers

DTP is a drop-down menu-driven system. This
means that rather than having to learn and
remember various command sequences to get the
program to perform a specific task, you select the
option you require from the list (menu) displayed
on the screen, using a pointer.

To do this you simply move the pointer to the
desired item, which will then be shown in reverse
colour. Then press the Select (Enter) key, or the
mouse Select button. From now on we will refer to
this action as ‘clicking’, which is standard mouse

5



terminology.

You move the pointer using either the arrow
keys (with Shift pressed for a slower rate), or the
mouse. Pressing Alt and one of the arrow keys will
cause the pointer to move immediately to the edge
of the screen dependant on the arrow key pressed.
For example Alt + 7 will move to the top of the
screen.

To cancel a menu, click on the Cancel option
within the menu, or hit either the Can or Relay
keys. Throughout the DTP package pressing these
keys will always take you back to the start of an
operation. You can see the functions allocated to
the keys in the diagram opposite.

The drop-down menu system is an extremely
simple and safe way to perform your tasks, so feel
free to experiment. Rest assured that there is noth-
ing you can do to damage the software. If you do
happen to make a mistake, the software will inform
you and no action will take place.

Note that when you save your data, you have
saved a file and not a program. Therefore it has to
be loaded via the appropriate Load option from the
menu. It will not work if you attempt to run it.

The Options menu

You can go directly to the Options menu at any
time. You activate it by pressing the Paste key (or
combined mouse buttons). It offers facilities to
invert the screen, change the default drive (for
twin-drive systems) and provides functions for use
with the mouse.
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Keyboard Designations

[F] Fine movement key [E] Cancel key
[E] Select key [3] Pointer movement keys
[0 Options key [E] Edge movement key




The mouse

If you intend to operate DTP under mouse control,
you must use the Options menu to initialise it and
select the correct kind of mouse. Once you have
done this you will be able to move the small pointer
around the screen using the mouse instead of the
keyboard. You will be able to save this configura-
tion if you so wish, so that on subsequent occasions
when you use DTP it initialises for mouse use
automatically.

To select menus and options with the mouse,
move the pointer to the label and click the left-hand
button. The right-hand button is used for cancel-
ling. If you are fortunate enough to have a middle
button fitted to your rodent, you can use this to
bring up the Options menu. To obtain the Options
menu with a two-button mouse, click the left-hand
button while keeping the right-hand button
pressed.

Also in the Options menu are the Pad Area
choices, which allow coarser or finer movement of
the pointer. The best way to find out their effects is
to experiment with different settings.

While every effort has been made to ensure the
accuracy of the program and manual, we cannot
accept responsibility for any imperfections in
them. Our policy is one of continuous improve-
ment and we reserve the right to change any part
of DTP.




KEMPSTON ~ ELECTRIC STUDIO AMX

Use the Options menu when you wish to operate
The Desktop Publisher under mouse control



Loading a page is simply a matter of clicking on the filename required
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Learning
the ropes

Setting up

Editing a page

Loading a page

The Tutorial

The object of this section of the manual is to provide
you with immediate hands-on experience in using
DTP’s three editors. In order to do this we have
included a ready-made page file on the disc along
with some text and graphics windows.

You can use these to experiment with some of
DTP’s facilities. Further information on all options,
including those mentioned briefly in this section,
can be found in the main part of the manual.

If you intend using a mouse for input, the first
thing you must do is initialise the system for it.
Press the Paste key to produce the Options menu
and use the arrow keys to move the pointer to
select Mouse. A subsequent menu allows you to
select AMX, Kempston or Electric Studio.

The Page Editor is the section around which
everything else revolves. It is where text and
graphics windows are created, where the page
layout is manipulated and from where the finished
copy is printed. Therefore it is logically the best
place to start. To get into it simply click Edit Page
on the top line of the opening screen.

During our experiments we will not save
anything to disc, so you can position windows
anywhere you wish and draw whatever you want.
You can abandon it when you've finished.

To begin with we’ll load in the sample page from
the disc and try out some of the functions in the
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Moving windows

Page Editor to see how to manipulate the page
layout. So first of all, turn the disc over.

To the right of the screen you will see a rec-
tangular box which represents the A4 page you will
be editing. Select File from the top line and choose
the Load option from the drop-down menu.

A list of filenames will appear from which you
should click on the file PAGEDEM. This will be
loaded and you will see three small rectangular
boxes positioned on it.

These are text and graphics windows: The
graphics windows are shown empty, while text
windows are filled with lines. Each line represents
a line of text that will be printed on the final copy.

Windows can be repositioned anywhere on the
page. To try this out, click Modes and choose the
Move Window option. Click on the rectangular
graphics window and you will be able to “pick it up”
and move it round the page.

By clicking again you can put it down anywhere,
even inside another window. Alternatively,
clicking Cancel will return the window to its
original position.

For this exercise, pick up the window and centre
it at the top of the page, a short distance from the
top edge. Now pick up the second graphics window
(the square one) and middle it under the first.

Now deal with the text window in exactly the
same way. You'll find that you can’t position it with
the pixel accuracy that you could the graphics
window, as it falls automatically on a character
boundary in order to be printed correctly. Place this
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Name that
window

Deleting
windows

window a short way up from the bottom edge. Your
page should now look like the diagram above.

Just like the page you are editing, all windows are
individually identified when they are created. To
see the names allocated to the files on the disc,
choose the Show Window Name option from the
Modes menu and click on the window you want to
identify. Try each one in turn to reveal its filename
— you’ll need this information later.

Now we’ll try deleting windows from the page.
Select Delete Window from the Modes menu then
click on the window you want to remove. This does
not erase the file from the disc, but just removes
any reference to it from the page. Try this out now
on each of the three windows you have just pos-
itioned.
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Adding windows

When you’ve carried out this exercise correctly
you will have a completely blank page. To recover
the situation we could reload the whole page, but
here’s an ideal opportunity to try out the option to
add individual windows.

To add a window you select either the Add
Graphics Window or Add Text Window option from
the Modes menu. Click where you want to locate
the top-left corner of the window, bearing in mind
that you can always adjust its position afterwards.
Click again and you will be prompted for the
filename of the window you wish to add.
So, to bring back our sample page:

Click on Add Graphics Window
Click location for top-left corner
Click, then select GRADEM1
Click on Add Graphics Window
Click location for top-left corner
Click, then select GRADEM?2
Click on Add Text Window
Click location for top-left corner
Click, then select TEXTDEM

Your page should now be as it was before you
started to experiment with the Delete option.

It is worth mentioning here that the only way
you can see the contents of any window in full size
is by loading it into the appropriate editor or by
printing the full page. However, you can see it in
reduced form using the Preview option. As we are
shortly to use the Text and Graphics Editors we’ll
also take this opportunity to view the page con-
tents by printing it out in draft form.
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Editing text

Moving around

Character styles

First check that your printer is set up and ready,
select Draft Quality from the Print option on the
top line and the page will be printed out. When
printing has finished, follow the prompts to re-
install the system disc.

So far we've seen how windows are created, pos-
itioned, moved, deleted and added to a page. Now
we can take a look at how the contents of the
windows are developed in the appropriate editors.
To start we'll look at the Text Editor.

To get into the Text Editor you first need to select
Edit Text from the top line of the main menu
screen to which you will have just returned. Click
the File option and select TEXTDEM from the list
of filenames displayed. The Text Editor’s work area
will now appear with the file you have selected
ready for editing.

Move the pointer into the Text Editor window and
click Select. The pointer will be replaced by a
cursor. From now on text will be entered from the
keyboard at this cursor and deleted using the
Delete keys.

The cursor is controlled by the arrow keys as
normal, with the mouse inoperative. Try deleting
some of the existing text and entering some of your
own by inserting it into the original or adding it to
the end.

You can type on the screen in different styles such
as italic or bold. To do this, click Cancel and use the
pointer to select the Styles option. Choose Bold and
click again to bring back the text cursor.
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Editing graphics

The layout

Painting

Try typing again and you will see that the text
appears on the screen in bold. Now use the menu to
remove bold, and enter some more text, this time
selecting the Italic option. All styles are shown on
the screen more or less as they will appear when
the page is finally printed out.

Now you’ve experimented with the Text Editor
we’ll move on to look at how graphics windows are
made up.

To get into the Graphics Editor you first need to
leave the Text Editor. Get back to the main menu
by clicking File and Abort without saving.

Click the Edit Graphics option to initialise the
Graphics Editor and click GRADEM1 in the list of
filenames.

A drawing will be displayed on the screen: On its
left is the patterns menu which contains the
designs with which you can paint or fill areas. On
the right are the different brush shapes you can
use when painting.

So that you can have a clean area to experiment
on, you must first remove the previous picture from
the screen. Select the Clear option from the top line
then either Screen or Window from the drop-down
menu — it doesn’t matter which for this exercise.

Now click Tools. The drop-down menu that
appears contains all the facilities available to you
for editing graphics and you select one by clicking
the option you require. We'll try some of them out.

First click the Brush option. Move the pointer over
the drawing area, click Select. When you move you
will paint the currently selected pattern using the
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Drawing lines

gl
il
RAYS
BOX
TRIANGLE
ELLIPSE
TREEHAD
BRUSH
INVERT
HAGNIFY
FILL
COPY
MOVE
TEXT
cut
FiSTE
CANCEL

Drawing shapes

currently selected brush shape. These are indicated
at the bottom left and right of the screen. Pressing
Select or Cancel will stop the painting operation to
allow you to move the brush to a different area.

Try out some of the different brush shapes and
patterns by simply clicking an alternative in the
appropriate menu. If you select the pattern rep-
resenting the screen background, this will provide
an ideal means of wiping out errors, with the option
to reduce the size of the eraser from the brush
shapes menu. Once you are happy with the paint
operation, clear the screen as before.

Now let’s try out the line drawing facilities. Select
Line from the Tools menu, then click the start and
end points of the line. Note that the line is not fixed
—you can move it to the position required and click
again to fix it.

You can experiment here with the facility to lock
lines in the position they are initially drawn. Bring
up the Options menu, then click on Line Lock: A
small arrow alongside will indicate that this is now
on. Now draw a new line and note how it is
immediately fixed in the position you draw it.

Return to the Tools menu, select Rays, and
providing Lock is still on you will be able to draw a
series of lines radiating from the same point.

Once you've got the hang of drawing lines, fixed
or otherwise, clear the screen and we’ll move on.

Before we start with shapes, bring up the Options
menu and click on Line Lock. The small arrow will
disappear as the option is turned off.

Now select Box from the Tools menu. Click the
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CANCEL

Fill

point where you want the top-left corner then move
and click the opposite corner and an outlined box
will appear.

As with line drawing the box’s position is not
fixed, so you can move it to any position on the
screen then click to fix. Note that outlined box
drawing has the same options available as line
drawing. Try changing the line thickness and style
using the options in the Line Style menu.

The other shapes in the Tools menu work in a
similar way. Try the triangle and the ellipse —
they're just as easy to produce.

The only thing to watch out for is that when you
are drawing an ellipse, you first pull a rubber-
banded box to the size of the ellipse required. So if
you want to draw a circle, remember to create a
square first. Try it and see for yourself.

While you've got a variety of shapes on the screen
it’s an ideal opportunity to try out the Fill option.
This is used to fill an outlined shape with the cur-
rent pattern.

Test this by choosing the Fill option from the
Tools menu and place the pointer inside one of the
enclosed shapes on the screen. Click Select and the
shape will be filled.

Note that if there is any gap in the shape’s out-
line the fill pattern will leak out. You’ll see this
happen if you attempt to fill any shape which has
been created using a dotted outline. In this case
click Cancel to stop it.

Once you’re happy with the fill options clear the
screen again and we’ll try some freehand drawing.
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Freehand
drawing

Magnify

Copy

Proper freehand drawing is only really efficient
when using a mouse, due to the way that your
Amstrad reads its keyboard.

Select Freehand from the Tools menu. Use the
pointer in exactly the same way as with painting
except that your alternative options are in the Line
Style menu instead of different patterns and brush
shapes.

Clicking Select will draw as you move, while
clicking again will halt the drawing operation. Just
move around the window drawing lines wherever
you wish. Using these lines you can now try out the
magnify facility.

Select Magnify from the Tools menu. Move the
pointer on to the drawing area, click once and a box
will appear. This is your “magnifying glass”. Move
it to an area of the screen you would like to enlarge
and click Select. Your chosen area will now be
displayed in enlarged form. You can set or unset
individual pixels by clicking on them. Notice that
any changes you make appear on the drawing so
you can see what effect they are having. Click
Cancel to finish.

You can copy any area of the screen to another
area using this facility. First choose Copy from the
Tools menu. Pull a box the size you require by
clicking the first corner, then move and click the
opposite corner. Move the box over the area you
want to copy and click again.

Now move the box to a different part of the
screen, click again and the area will be copied.
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Text
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Each time you click a new copy will be drawn. Try
it out several times then click Cancel to finish and
clear the screen as before.

Enlarged text can only be produced within the
Graphics Editor. You can create areas just like the
heading you saw on our sample page. In fact if you
select the File option, then load the GRADEM1
window you can see what this looks like.

In order to create some of your own you will first
have to load a font using the Read Font option in
the Text Style menu. Now clear the screen again,
then click on the Text option in the Tools menu. To
use this facility you first pull a box the size that you
want each character. As before, click the first
corner, move, then click the opposite corner.

Now move the box to the point you want your
characters to start and click again. Anything typed
from the keyboard from now on will appear on the
screen at your chosen size. Click Cancel to finish.

Use the Text Style option on the top line to write
in different directions. For instance, clicking on Up
will allow you to write up the screen; clicking Left
will allow you to enter text from left to right, that
is, upside down. Try out the various options.

Once you have experimented with all these
options you should be confident enough to attempt
to create your own page. To save your work as you
go along, remove the system disc and replace it
with one that you can write to.

We have only looked at a few of DTP’s facilities
in this tutorial section. There’s much, much more
to come in the main part of the manual.
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A selection from the Clip-Art supplied with The Desktop Publisher
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Mouse

Pad Area

DTP’s main features

This part of the manual contains full details of all
the options available within the DTP package. It is
split into sections for ease of use, and these are
dealt with in the following order:

@® The Options Menu
@ The Page Editor

@® The Graphics Editor
@® The Text Editor

® The Font Editor

@® Disc Filing options

The Options menu

This menu contains functions which affect oper-
ations in all areas of the DTP package. It can be
called up at any time by pressing the appropriate
mouse button(s) or the Paste key. The new con-
figuration for all options can be saved to the system
disc if required so that on subsequent use of DTP
the default settings meet your requirements. The
options available are as follows:

If you wish to operate the package under mouse
control you must use this option to initialise your
particular rodent. Until you have selected a par-
ticular brand of mouse you can only move the poin-
ter using the keyboard. The AMX, Kempston and
Electric Studio mice are currently supported.

This is used to adjust the distance moved by the
pointer for a given distance moved by the mouse.
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Drive A,B

Line Lock

Invert

Save

Pad area A is the coarsest; pad area E is the finest.
Coarse pad areas are useful for rapid movement
but cause the pointer to move in large less-
controllable steps. Fine pad areas are useful for
freehand drawing or detailed work .

The current drive for disc operations is selected
here. Drive M is not supported as this is reserved
exclusively for DTP’s own use.

Functions which use rubber-band outlines such as
creating windows, shapes and lines have a facility
to immediately lock in position the initially defined
shape if this is preferred.

Under normal circumstances you can define a
box or line, then move it to the required position
before actually setting it. This situation can be
altered by toggling Line Lock on and the object will
be drawn immediately, locked in position .

The foreground and background colours of the
screen display can be inverted any time.

Bear in mind that the printing process inverts
the colours so that what was white on black is
printed as black on white and vice versa. This
option is therefore particularly useful in the
Graphics Editor as it allows you to see your draw-
ings and characters on the screen as they will be
printed on the paper.

Changes to the initial configuration of any of the
above facilities can be saved to the system disc if
required. This means that on subsequent use of the
DTP package the default settings will meet your
requirements.
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Add Graphics/
Text Window

Move Window

Using the Page Editor

The Page Editor is used to design the initial layouts
of your pages, and contains the necessary options
to create and move Graphics and Text Windows.
There are also facilities available for previewing
and printing out the final page, and for saving and
loading files to and from disc.

The Modes menu

These options are used to add ready-prepared
graphics or text windows to the page being edited.
If a window is added to a position where it will
overlap the edge of the page it will automatically be
moved to the nearest allowed position.

To use this option simply click the pointer
anywhere within the page boundary, click the
window name from the displayed list, move the
window to the required position then click again to
fix.

If Line Lock is enabled, the initial click of the
pointer should be at or near the top-left hand
corner of the position required for the window,
bearing in mind that if the position is not quite
correct it can be adjusted using the next option.

Graphics and text windows can be moved about on
the page being edited. Graphics windows may be
placed anywhere on the page, pad area permitting.

Text windows may only be positioned on 10-pitch
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Remove Window

Create Graphics/
Text Window

character boundaries so that all text on the page
lines up correctly. The best way to lay a page out
therefore is first to locate all text windows, then
initialise and position the graphics windows which
can be manoeuvred more accurately. Windows may
overlap if required.

To use this option, click the window to move,
move it using the mouse or cursor keys, then click
again to fix in its new position.

This option is used to delete windows from the page
being edited. However, removing a window does
not erase it from the disc which means that the
window can be used again on a different page if
required. Windows can only be erased from the disc
using the Disc Filing options (see later).

To operate this function,just click on the window.

This option is the one used to originate a blank
graphics or text window for use within the appro-
priate editor. When created it will be saved to disc
as soon as you enter the filename and will remain
in existence until erased using the Disc Filing
options.

After establishing the shape and size of the
window you will be able to move it around before
fixing it within the limitations described in the
Move Window section.

It’s worth noting that graphics windows take up
a lot of memory — in fact more than ten times that
of an equivalent sized text window. As a guide a
graphics window 5cm X 10cm square will require
about 3k of memory.

Text windows are created using the current font
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Show Window
Name

Show Text
Window Font

selected from the Font menu. There is also a
minimum width for text equal to two 10-pitch
characters. To use this option, simply click the top-
left corner of the window and pull the bottom-right
corner to create the size of window you require.
Now click again and move the window to the
required position. Click again to fix it and enter a
filename when requested.

The filename of any window can be discovered by
clicking the window on the actual page. It is a good
idea to give windows descriptive filenames to make
identification easier — for instance HOUSEPIC
rather than DRAWINGI1 is much more use on a
disc full of filenames.

This is used to display the font used by any text
window. Once you have created a text window this
is the only way you can find out what font was
chosen other than by printing out the page.

The Fonts menu

These fonts exactly match those used by the Loco-
Script word processor and are as follows:

Pica: 10 characters to the inch

Elite: 12 characters to the inch

Condensed: 17 characters to the inch

Double Pica: 5 characters to the inch

Double Elite: 6 characters to the inch

Double Condensed: 8.5 characters to the inch
Click to select the font required. Text windows
created from now on will all use the selected font.
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Draft Quality

Near Letter
Quality

Printer-type
option

The Print menu

This option is used to print, in draft quality, the
page being edited. An average page printed in this
format will take about three minutes. As some
graphics information is lost when draft printing its
main use should be limited to checking that the
paper is lined up and graphics and text blocks are
correctly positioned before printing in Near Letter
Quality mode.

Used to print, in near letter quality, the page being
edited, with an average page taking about fifteen
minutes to process. Because the print option
accesses the disc to process the necessary window
information, when either of these options is
selected there is a slight processing delay before the
printer actually bursts into life.

Provides facilities for you to choose between the
Amstrad PCW printer (default), and any Epson
compatible used with the standard PCW centronics
interface.

The Preview option

Reduced representations of the graphics windows
on the page layout being edited can be displayed
when required.

Previewing a page displays the contents of the
graphics windows in miniature rather than just the
window outlines and gives you a better idea of how
the finished product will look when printed out.
Text windows are still shown as a series of lines.
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Save and Exit

Save and
Continue

Save as

The Create option

Unless you are loading an existing page, this will
be the first operation you carry out, to create a
blank page for editing, and on which to initialise
your graphics and text windows. To enter a
filename click the input box at the bottom of the
drop-down window above the Cancel option.
Filenames may be up to eight characters long with
each page taking up 1k of memory on the disc.

You can only create graphics and text windows
when actually in the process of editing a page, but
once the windows have been created the page can
be dispensed with by aborting if it is not needed. In
this way you can create text and graphics windows
which are not associated with a particular page but
which can be used later with any.

An important point to remember though is that a
page must always be on the same disc as the win-
dows used by it.

The File menu

Used to save the page being edited using the
original filename, and leave the Page Editor. Make
sure that your data disc is in the current drive.

Used to save the page being edited under the
original filename, without leaving the Page Editor.
Use this function to save the page you have been
editing before loading a new one.

Used to save the page being edited but under a
different filename. This allows you to save the page
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Abort

Load

Point

without over-writing the original file. Simply click
on the empty box in the drop-down window and
input the filename required.

Used to leave the Page Editor without saving the
page being edited. Useful if all you want to do is
examine a page.

Used to load an existing page for editing. The page
name will appear at the top-left of the layout when
it is loaded.

Click the filename required from the drop-down
list displayed. Should there be more files than will
fit in the window the list can be scrolled by clicking
on the direction labels.

Using the Graphics Editor

The Tools menu

Within the Tools menu are many of the options you
will need to enable you to produce excellent quality
artwork. These options are simple to use and can
each be accessed by clicking on the required label
in the drop-down menu.

This is used to plot individual points on the screen.
Because on the PCW a pixel is twice as high as it is
wide, a point in DTP is plotted two pixels wide by
one pixel high so that it looks square. Points may
be plotted in normal or inverse colours and in dif-
ferent thicknesses selected from the Line Style
menu. The Style option has no effect here.
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Line

Lines

Rays

Box

This is used to draw a line between two points
using the current settings in the Line Style menu.
To draw a line simply click the start of the line,
click the end of the line, and move the line to the
position required. Click once more to set it in pos-
ition.
This is used to draw lines from point to point con-
tinuously. For this function to work correctly Line
Lock must be toggled on in the Options menu.
Using lines you can draw shapes other than those
provided in the Tools menu. If you don’t have a
mouse and therefore can’t use the freehand mode
easily, with practice and patience you can draw
curves by moving in small steps.

This option is ideal for drawing lines which radiate
from a central starting point, such as for adding
segments to a pie-chart. Just as with the Lines
option, this only works correctly with Line Lock
toggled on.

To use it, click the central point, then move and
click the end of the first line. This will be drawn and
a second line will begin from the starting point.
Move and click the end of the second line. This will
be drawn and a third line will begin from the start-
ing point and so on.

Squares and rectangles can be drawn using the
current settings in the Line Style and Shapes
menus. These can be useful for drawing bar charts,
in which case using a coarse Gridlock setting will
be of assistance.

To draw a box simply click the top-left corner,
move and click the bottom-right corner.
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Triangle

Ellipse

Freehand

This is similar to the Box option and is used to draw
triangles using the current settings in the Line
Style and Shapes menus. Using a solid tri-
angle in the background colour is a good way of
erasing things in awkward places. Also, because
most shapes can be made up of a number of them,
triangles are useful for creating areas of shading
where fill cannot be used.

Click the first corner, move and click the second
corner, then move and click the third corner. Move
the triangle to position required and click to set.

Circles and ellipses can be drawn using the current
settings in the Line Style and Shapes menus. A
rubber-band box is used to define the size of the
shape which will be drawn to fit snugly inside it.

We can demonstrate this option and some of the
others, by drawing a simple pie-chart:
First you need to draw a circle with a central point.
To do this, select a coarse Gridlock with a 2:1 ratio
(8,4 or 16,8) and place the pointer where you want
the centre of the pie-chart to be. Now plot a point
using the Point option from the Tools menu. You
can now draw an outlined circle around the point
you have plotted using the same Gridlock setting.
Now turn Gridlock off and from that central point
use the Rays option to create the pie-chart seg-
ments.

For routine use click the top-left corner, move
and click the bottom-right corner and move to the
position required. Click again to set.

This is used to draw a line following the movement
of the pointer using the current settings in the Line
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Brush

Magnify

Fill

Style menu. This option is really only useful if you
have a mouse, although it can be used instead of
the Line option with a coarse gridlock setting.

To get a smooth line you will need to use fine pad
areas and Gridlock set to off. Thicker lines take
longer to draw and therefore need to be drawn
more slowly to get a smooth curve.

Used to paint areas in freehand using the current
brush shape and pattern selected from the menus
displayed on the left and right of the screen. This
option is again most useful with a mouse.

You can enlarge selected areas and edit them pixel
by pixel. When you select this option the pad area is
temporarily set so that each key press of the key-
board moves the pointer by one (magnified) pixel.
Even if you have a mouse, with a fine pad area
defined, you may still find it easier to use the key-
board for editing purposes. Magnify will not work
on very short windows.

To operate, click on the area of the window to be
enlarged and a hover box will appear. Move the box
over the area you want to magnify and click again.
You can now toggle pixels on or off by clicking
them.

Enclosed areas can be filled using the currently
selected pattern. Note that any gap in the outline
of the area you wish to fill may allow the pattern to
escape. To allow for this, or just in case you don’t
like the pattern after you have used it, it’s a good
idea to use the Save and Continue option first. Bear
in mind also that the fill may be stopped at any
point by clicking Cancel.
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Copy

Move

Text

The fill does not always succeed completely on
complicated shapes — in this case just fill areas left
blank separately.

Fill will work on any black shape surrounded by
white or white shape surrounded by black (such as
text). Make sure the pointer is placed inside the
border of the shape you wish to fill otherwise you
may fill the border rather than the area inside.

To fill an area just place the pointer inside the
area and click.

This is used to create a copy of any selected area of
a window in a different position in that window.
Copy literally duplicates the defined area in the
new position.

You can create multiple copies of the same area,
and it is*also another good way of correcting mis-
takes by copying a blank area to the parts you
want to erase.

To operate, click the top-left corner of the area to
copy, move and click the bottom-right corner, then
move the outline over the area you want to copy.
Click to fix it and move the outline to the area to
copy to. Click again and the area will be duplicated.
Move to the next location and click again for
another copy and so on.

This option works in exactly the same way as Copy,
the only difference being that the original area is
erased once the copy has been made.

This is used to write text using the options selected
from the Text Style menu. Note that if you haven’t
loaded a font yet (using the Text Style menu) this
option will not work.
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Invert

Cut

Text is useful for labelling graphs and charts and
for producing larger and fancier characters for
headings and such like.

To use this option click the top-left corner of
desired character position, move and click the
bottom-right corner and move the outline to the
position required. Click again and the outline will
change into a box cursor. You can now type charac-
ters, delete them and move the cursor in character
steps using the cursor keys. An 8 X 8 gridlock
setting is recommended for the neatest shape of
text.

Used to invert the colour — either of a small section
or the whole window. To invert a window that can’t
be displayed all at once, invert the first section then
move the window and invert the second section and
SO on.

To operate, click the top-left corner of the area to
invert, move and click the bottom-right corner,
then move the outline over the area you want to
invert. Click again and the area will be inverted.

Used to create a copy of a selected area of one file
and save it to disc. It can later be added to another
file using the Paste option. Cut only works up to
the size of the displayed part of the window being
edited.

This is the ideal option for making full use of the
page of Clip-Art supplied on the disc with DTP.
Small areas can be cut and any bits of artwork not
required can be erased after the drawing has been
pasted into its new window.

To use, click the top-left corner of area to cut,
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Paste

move and click the bottom-right corner, then move
the outline over the area you want to cut. Click
again and enter a filename when requested.

Bear in mind that when creating the box, the
step sizes along both axes are predefined, and you
may not be able to make it the exact size.

Used to scale and import windows from disc on to
the window being edited. You can add any graphics
window to the one you are editing, and scale it up
or down to fit. If you try to add a window which is
larger than the screen or the window you are
editing it will be scaled down automatically to fit.
You will still be able to scale it down further if you
wish.

You can use this option to add pre-defined shapes
such as kitchen fitments or electrical symbols to
your drawings. The best way of creating pre-
defined symbols is to draw several in a larger
window and then cut them out and save them sep-
arately. Remember to delete the larger window
from the disc (using the Disc Filing options) when
you have finished or you will rapidly run out of
space. Choose names carefully so you will know
which is which when you want to use them later. It
is a good idea to keep pre-defined shapes on a disc
of their own.

To use, click the top-left corner position of the
window to add, click the window to add from the
list. Move the top-left corner of the window outline
to the position required and click again. Move the
bottom-right corner to scale and click once more.
The window will now be scaled and added.
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Colour

Thickness

The Line Style menu

Line colour can be altered by selecting between
background and foreground. As in other options
this affects only the colour used by line drawing
and has no effect, for example, on brush or fill
modes.

The thickness of the line can also be doubled or
tripled. When drawing lines or boxes the rubber-
band outline will appear thin regardless of line
thickness selected. When the line is drawn it will be
widened evenly on both sides of the rubber-band
outline.

The style of lines can also be changed between 16
different combinations of dots and dashes.
Choosing, for example, a simple dotted line, the
dots will be placed at different distances apart
depending on the line thickness selected. This is so
that the proportions are always correct as the dots
themselves become larger.

The Shapes menu

Outlined, solid, or outlined and solid shapes can be
chosen. Drawing outlined and solid boxes is a good
way of creating bar charts. A solid box in the
background colour can be used to erase areas of a
picture or, using a pattern, to create large areas of
shading.
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Read Font

Right, Down,
Left, Up

Inverse

The Text Style menu

This is used to load the font required from one of
those supplied or one of your own created using the
Font Editor.

Fonts need not contain letters: You could for

instance, create a font consisting of electrical
components. Alternatively you might prefer to
design different logos in place of letters.
Text can be set to go in any direction on the screen
using this option. The text cursor will be
automatically moved in the chosen direction each
time you type a character. If you try to type beyond
the edge of a window a new line will be started. If
you type on a window which is larger than can be
displayed at once, the window will be
scrolled when you reach the edge .

This option is used to select reverse text mode in
which the background and foreground colours of
the text are inverted. So on a black screen you
could opt for black text inside a white border.

The Gridlock option

Used to set the gridlock size. Gridlock is useful for
instance, where you need to create images with
accurate proportions such as graphs or charts.

Normally if you move two pixels left or right on
the screen this is the same distance as moving up
or down by one pixel. Gridlock options are therefore
supplied that allow you to step by twice as many
pixels on the X axis than the Y.
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SCREEN
NINDOW

CANCEL

Save and Exit

Save and
Continue

Save as

Abort

Load

The Clear option

This is used to clear the window or the area of
window displayed on the screen. Clearing the
screen will blank only that part of the window
which you can see. Clearing the window clears not
only the screen but the remainder of the window
(stored in the computer’s memory) as well.

The File menu

Used to save the window being edited using the
original filename, and leave the Graphics Editor.
Make sure that your data disc is in the drive.

Used to save the window being edited under the
original filename, without leaving the Graphics
Editor. Use this function to save the page you have
been editing before loading a new one.

Used to save the window being edited but under a
different filename. This allows you to save the
window without over-writing the original file.
Simply click on the empty box in the drop-down
window and input the filename required.

Used to leave the Graphics Editor without saving
the window being edited.

Used to load an existing window for editing. The
window name will appear at the top-left of the
layout when it is loaded.

Click the filename required from the drop-down
list displayed. Should there be more files than will
fit in the window the list can be scrolled by clicking
on the direction labels.
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Patterns and
Brush Shapes

Movement
arrows and
Window position
indicator

Miscellaneous options

Various patterns and brush shapes can be selected
from the menus displayed down the left and right
sides of the screen. The box below each displays the
current selection.

These are used to scroll around the window being
edited. If the window you are editing is too large to
be displayed all at once you will need to scroll from
one part to another.

At the top-right of the screen is a diagram of a
box within a box. The outer box represents the
window you are editing while the inner box shows
the part you can see on the screen.

At the top-left of the screen there are four direc-
tion arrows. Clicking on one of these will cause the
indicator box to move in the direction selected. The
window will not actually be scrolled, however, until
you click the ‘move’ icon at the bottom right of the
arrows. Clicking the bottom-left box will reset the
indicator to its starting position.
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Using the position indicator to view the area of window not on the screen
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Using the Text Editor

The Text Editor contains all the options needed to
process text, ranging from file handling to format-
ting and style selection; from ruler line alterations
to importing text from other word processors.

The Style menu

This is used to select the character style required
using either Bold, Italic, Underlined, Superscript,
or Subscript text.

Character styles are displayed on the screen as
near as possible to their actual appearance when
printed. Styles may also be selected by pressing the
+ and — keys as in LocoScript (enable/disable italic:
+/-1, bold: +/-B, superscript: +/-SR, subscript:
+/=SB, underline +/-UL).

As an example, to write HELLO in bold you need
first to click the bold option from the Style menu (or
hit +B) to turn bold on, then type HELLO and
finally click the bold option in the Style menu again
(or hit —B) to turn bold off.

Alternatively you could type HELLO first and
then position the cursor over the H, turn bold on as
above, move the cursor to the O then turn bold off
again.

You can select more than one style at the same
time. Style codes are attached to the first and last
characters of the words affected.

To refresh the screen styles manually just hit
+R.

46



Right Justify

Centre Justify

Window Length
Lock

The Edit Ruler option

Tab stop positions on the ruler can be altered using
this option. Tabs are generated using the Tab key
and appear as a right pointing arrow in the text. If
you hit the Tab key when the cursor is beyond the
last stop on the ruler it will be ignored. Note that in
some cases removing or adjusting tab stops may
cause tabs in the text to be removed.

Adjusting the ruler will cause the cursor to be
returned to the top of the text. To use: Move the
cursor on the ruler to the required position and hit
the Tab key to toggle the tab stop on or off.

The Format menu

This is used to set right justification fot the window
and causes the entire text in a window to be padded
out with sufficient spaces to give both left and right
even margins. If you select right justify while
editing a window, existing text will not be re-
formatted until the cursor is moved down beyond
the end of the window or the window is saved.

Text can be centered on the cursor line using this
option. If you alter a centred line it will need to be
re-centred. You can also hit +C to centre a line as
in LocoScript.

This is used to lock the current window length
setting. Under normal circumstances when you
save a text window it will be automatically
adjusted to the number of lines of text.

This means that if you create a text window in
the Page Editor that is, say, ten lines long but only
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type five lines of text, the window will be
automatically shortened to this new length.

Now it may be that you hadn’t finished editing
the window and wanted to add some more text
later to fit exactly in the original window. Or it may
be that you particularly wanted to leave the space
for something later.

Using this option will retain the original length
of the window even though there is not enough text
to fill it yet.

Please note however, that if you type more text
than will fit in the original length the option will be
overidden and the window will be saved to the new
extended length.

The Add Text menu

Text can be incorporated into a window from either
another window or directly from an Ascii file.

To add text created with LocoScript for instance,
you first need to convert the file to Ascii using 7
Modes, and put it in group 0, making sure to end
the filename with the .ASC extension.

When you wish to add text from another text
window any formatting is removed and the text is
re-formatted to fit, but character styles are
retained.

The File menu

Used to save the window being edited using the
original filename, and leave the Text Editor. Make
sure that your data disc is in the current drive.
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Save and
Continue

Save as

Used to save the window being edited under the
original filename, without leaving the Text Editor.
Use this function to save the window you have been
editing before loading a new one.

Used to save the window being edited but under a
different filename. This allows you to save the

General notes

Formatting: Lines are normally formatted as
you type, but if you go back and correct some
text this will only be completely re-formatted
when you move the cursor beyond the end of the
corrected paragraph (indicated by the left poin-
ting arrow).

Saving a window will automatically format
any unformatted paragraphs. You can’t change
the font used by a window, but you can add text
from a window with a different font. The font is
then changed to the one used by the window
being edited.

Window length: When you type more lines of
text than will fit the length of a new text window
a message will appear to tell you this. Should
you wish to retain the original window size, the
text must be edited to fill the window without
bringing up the message.

When you save the window its length will be
automatically reset to the number of lines of
text you have typed (unless you have selected
window length lock).
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Abort

Load

window without over-writing the original file.
Simply click on the empty box in the drop-down
window and input the filename required.

Used to leave the Text Editor without saving the
window being edited. Useful if all vou want to do is
examine a window.

Used to load an existing window for editing. The
window name will appear at the top-left of the
layout when it is loaded.

Click the filename required from the drop-down
list displayed. Should there be more files than will
fit in the window the list can be scrolled by clicking
on the direction labels.

Using the Font Editor

The DTP package has a useful built-in Font Editor.
Using it you can quite easily extend the range of
fonts supplied on the disc, by creating some of your
own.

When you select the option you automatically
enter the Graphics Editor with the Magnify option
enabled and Gridlock set to X=16:Y=16. This
ensures that the outline box moves a character
block at a time.

First select a font from the drop-down list dis-
played. The whole font will then be presented as
the contents of a graphics window ready for
editing.

Creating a new font is then simply a matter of
using the magnifier as a character definer to set
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Rename

Copy

Delete

and unset pixels as required. When complete the
font can then be saved to disc for later use. Bear in
mind that unless you wish to overwrite the original
font file, you must save with a different filename
using the Save as option in the File menu.

The Disc Filing section

The Disc Filing section contains all the facilities
youll need to maintain your files — cataloguing,
renaming, copying and deleting.

This is a simple way to give page and window files
alternative titles. However, it is important to note
here that if you rename a window, any page
references to it will not be updated. This means
that when you next edit a page that used the
original window name it will fail to find it. You will
need to use the Add Window option with the new
filename in order to replace it.

You can generate a copy of a file on the current
drive using this facility — useful if you want to
create a window which is a modified version of an
existing one.

Copy will not allow you to go from one disc to
another. To do this you need to load the file into the
relevant editor and save it again after swapping
the disc. To copy from A to B on a dual-drive system
you should load the file into the relevant editor and
change the default drive in the Options menu
before saving it again.

Used to erase a file from the disc. Note that
references to a deleted window will remain in pages.
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which used it. This means that if the page is edited
later it will look for (but not find) the deleted
window name. Saving the page subsequently will
automatically remove the reference to the deleted
file.

Directory Catalogues selected filetypes on the current drive.
P
GR“%HICS WINDOW ngeral ‘notes.
TEXT WINDON Filenames: Filenames in the same group such
ASCII as text windows, cannot have the same name,
FONT however you can use the same name for files in
CANCEL different groups.

This means, for instance, that you can have a
text window and a graphics window with the
same name. Filenames can be up to eight
characters long but full stops, colons and spaces
are not allowed. Other characters such as
underscore and minus are not suppressed but
may not be acceptable to CP/M commands such
as PIP.

You don’t have to specify file extensions and
they are not displayed. However, they are set
automatically by the program to allow it to dis-
tinguish between different filetypes.

The DTP disc has not been protected against
copying and it is therefore advisable to make a
backup copy. Text and graphic data however
should not be saved to the DTP program disc. A
separate formatted disc is recommended for this.
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Printing

Pad areas

Changing the
size of windows

General hints and tips

In order to print a page, DTP accesses the data disc
for each window file needed by the page, so the disc
must be in the current drive.

Before printing, the software sets the PCW
printer to expect continuous paper-feed so if you
are using a single sheet you won’t be able to access
its entire length because of the way the paper is
held. This means you must leave at least one inch
at the bottom of the page free of windows.

Also bear in mind that with any printer using
single sheets, the paper slips slightly as it is fed
through, making printouts somewhat shorter than
with continuous stationery.

Pad area alteration not only affects the mouse but
also the keyboard. For keyboard operation pad
area E is recommended.

If you find the need to reduce the size of a graphics
window because your artwork doesn’t fill it
competely, the best way to go about this is to cut
out the area of the drawing which will be saved to
disc under the filename you choose. Then all you
need to do is erase the original name from the disc
and rename the cut-out to the original.

Similarly if your window turns out to be too small
for your graphics, you can paste the whole area into
alarger blank window created for the purpose. You
should erase the original and rename the new
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Disc errors

window so that the Page Editor can find it.

The same applies to text windows should you
need to increase the width (the length will change
automatically provided Window Lock is set to off).

Mistakes when handling your discs may generate
the following non-fatal disc errors and their mean-
ings are explained.

File not found: Attempting to access a file not
present on the disc in the cur-
rent drive.

File exists: Trying to give a file a name that
already exists on the disc in the
current drive.

No disc space: The disc in the current drive is
full.

Disc error: Any of the following -
attempting to write to a write-
protected disc, attempting to
exceed the maximum number of
filenames allowed (64 for drive
A, 256 for drive B), any disc
failure.

To continue, just remove the cause of the error
and re-select the appropriate operation.

Should you try to access a disc which is not
present on the current drive, DTP will display the
message:

Insert disc in drive.

To continue, comply with the instruction, press
Cancel, and the operation you originally selected
will continue without loss of data.
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Quick Reference Section

When Line Lock is enabled, rubber-band boxes or
lines will be fixed in position as soon as they are
defined. If Line Lock is disabled the box or line
can be moved before its position is set by clicking.

The Page Editor

Function Operation
CREATE
Creates a new page, Enter filename and
replacing the one in press Return or Enter.
memory without
saving it.
FILE
Abort Abandons edit without | Click to select.
saving and Returns
you to main menu.
Load Loads a page for Click on filename
editing purposes, required.
replacing the one in
memory without
saving it.




Function

Operation

Save as

To save a file under a
different name.

Click to select, then
input filename.

Save and Continue

Saves file being edited
under original
filename without
returning to main
menu. Used to save
previous page before
loading or creating a
new one.

Click to select.

Save and Exit

Saves file being edited
under original
filename and Returns
to main menu.

Click to select.

FONT To select an alterna- Click on required
tive text font for a option.
window.

MODES

Add Graphics Window

Used to add a
graphics window to
the page being edited.

Move pointer to where
you want the top-left
corner of window to be
placed and click. Then
click on filename
required.
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Function

Operation

Add Text Window

Used to add a text
window to page being
edited.

Move pointer to where
you want the top-left
corner of window to be
placed and click. Then
click on filename.

Create Graphics
Window

Used to create a new
graphics window. Note
this option will only
function when a page
is being edited.

Move pointer to where
you want top-left
corner of window to be
placed and click. Pull
to create window size
required and click
again. Enter filename
and press Return.

Create Text Window

Used to create new
text window. Note this
option will only func-
tion when a page is
being edited.

Move pointer to where
you want top-left
corner of window to be
placed and click. Pull
opposite corner away
to create window size
required and click
again. Enter filename
and press Return.

Move Window

Used to position win-
dows on the page
being edited.

Click on window to be

moved. Move window.
Click to fix.
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Function

Operation

Remove Window

Used to remove a
window from page
being edited. Note this
does not erase file
from disc but merely
removes reference to
it from page.

Click on window to be
removed.

Show Window Name

Displays name of text
or graphics window.

Click on window
required.

Show Text Font

Displays font used by
text window.

Click on text window
required.

PREVIEW

Displays a reduced
image of the page.

Click to select.

PRINT
Draft

Used to print page
being edited, in draft
form.

Click to select

Near Letter Quality

Used to print page
being edited, in near
letter quality.

Click to select.
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The Graphics Editor

Function

Operation

move only on specified
grid positions.

CLEAR To clear entire window | Click on option

or area of window cur- | required.

rently on screen.
FILE To load, save, or abort | Click on option

file. required.
GRIDLOCK Allows pointer to Click on required grid

option.

LINE STYLE
Colour

Defines line colour.

Click on foreground or

Brush, Fill and Shapes
options.

background.
Style Defines line style. Click on required
style.
Thickness Defines line thickness. | Click on required
thickness.
PATTERNS Defines patterns for Click on required

pattern.
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Function

Operation

SHAPES
Outline

Provides for shapes to
be drawn as outlines
using current options
chosen from Line
Style menu.

Click on option.

Outlined and Solid

Provides for shapes to
be drawn solid and
outlined using current
options chosen from
Line Style and Pat-
terns menus.

Click on option.

Solid

Provides for shapes to
be drawn solid using
current pattern
selected from Patterns
menu.

Click on option.

TEXT STYLE
Read Font

To load required font.

Click and select font.

Right, Down, Left, Up

To select direction for
text.

Click required option.

Inverse

To select inverse text
mode.

Click to select.
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Function

Operation

TOOLS

Box Draws outlined, solid, Click top-left corner
or outlined and solid then opposite corner
box. and box will be drawn.

Brush Provides painting Place pointer where
facility using brush you wish to start pain-
options. ting and click. Move to

paint. Click Select or
Cancel to release
brush.

Copy Provides copies of an Uses a rubber-band
area in other positions | box to define area to
on drawing. be copied. Click top-

left corner then oppo-
site corner and area
will be copied when
you place box over
area you wish to copy
to and click.

Cut Cuts and saves area to | Uses a rubber-band

disc.

box to define area to
cut. Click on top-left
then opposite corner.
Enter filename and
press Return.
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Function Operation

Ellipse Draws outlined, solid, Uses a rubber-band
or outlined and solid box to specify dimen-
ellipses. sions. Click top-left

corner, then opposite
corner and ellipse will
be drawn.

Fill Provides for filling Place pointer inside
outlined areas with area you wish to fill
current pattern. and click. Abort by

clicking Cancel.

Freehand Provides for freehand Place pointer where
drawing using line you wish to start
styles and thickness drawing and click.
variations. Move to draw. Click to

release pen.

Invert Inverts selected area. Uses a rubber-band
box to define area to
be inverted. Click top-
left then opposite
corner of area.

Line Draws a straight line Click at beginning of

between two points.

line, then end of line
and line will be
drawn.
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Function

Operation

Lines

Draws lines continu-
ously from point to
point.

Click at beginning and
end of line and it will
be drawn. A new line
will be started where
last line ended. Line
Lock must be enabled
for this option to work
correctly.

Magnify

Provides for editing of
individual pixels.

Move pointer to
approximate area you
wish to magnify and
click. The box that
appears is your ‘mag-
nifying glass’. Move it
over area to be en-
larged and click again.
A magnified image of
that area will appear
on left or right side of
your drawing.
Clicking on a pixel
will cause it to invert.
Actual drawing will be
updated as you do this
allowing you to see
results before you exit.
To exit, click Cancel.
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Function

Operation

Move

Copies a defined area
from one part of
drawing to another,
then erases original.

Uses a rubber-band
box to define area to
be moved. Click top-
left corner then oppo-
site corner and area
will be moved when
you place box over
area you wish to move
to and click.

Paste

Point

Pastes another
window on to window
being processed.

Plots individual points.

Move pointer to loca-
tion that top-left
corner of window is to
be pasted and click.
Click on window name
required and a rubber-
band box will be
drawn to the size of
window being
processed. Click again.

Move pointer to
position and click.

Rays

Draws multiple lines
from a single point.

Click at beginning and
end of line and it will
be drawn. A new line
will originate from
start point of last line.
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Function

Operation

Text

Provides for text to be
added to drawing.

Move pointer to pos-
ition you wish text to
start and click. Move
to expand box outline
to size of character
you require and click
again. You can now
start typing. Abort by
clicking Cancel.

Triangle

Draws outline, solid or
outline and solid
triangle.

Click at first, second,
then third corner and
triangle will be drawn.

The Text Editor

ADD TEXT

Ascii File Used to incorporate Click on filename
text from a simple required.
Ascii file, into a
window.

Text Window Used to incorporate Click on filename

text from another
window into one being
edited.

required.
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Function Operation
EDIT RULER To create or reposition | Move cursor to tab
tab stops on ruler line. | stop then press Tab
key to set or unset.
FILE To load, save or abort Click option required.
file.
FORMAT

Right justify

Right justifes all text
in window.

Click to select.

Center justify

Centres text on cur-
rent line.

Click to select or press
+E

Window Length Lock

Prevents window
length from
automatically being
shortened to number
of lines entered from
keyboard.

Click to select.

STYLE

To select alternative
text styles and to
allow text to be
printed in a variety of
directions.

Click on option
required.
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Disc Filing.

Function Operation
COPY Creates a copy of a file | Click filetype then
on current drive. filename. Enter new
filename when
prompted and press
Return.

DELETE Deletes file from disc. Click filetype then
filename.

DIRECTORY Catalogues disc in cur- | Click filetype to be

rent drive. catalogued.

EXIT Returns to main Click to select.

menu.

RENAME Renames file. Click filetype then
filename. Enter new
filename when
prompted and press
Return.
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The Options Menu

Function

Operation

Drive A

Drive B

Selects current drive.

Click drive required.

Invert

Inverts screen colours.

Click to select.

Line Lock

Causes all functions
which use rubber-
banded boxes or lines,
to be drawn as soon as
defined.

Click to select.

Mouse

Used to configure DTP
for AMX, Kempston,
or Electric Studio
mouse.

Click mouse required.

Pad Area

Used to set distance
pointer travels for a
given mouse
movement.

Click area required.
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